Ethernet Fabric (VDX, CNA)

Reply
Highlighted
Occasional Contributor
Posts: 8
Registered: ‎04-07-2017

VDX6740 - VXRail Setup!

Hello everyone,

 

I was wondering if anyone had any experience in setting up the VDX6740 switches. We've recently purchased new VX-RAIL fabric which comes along with the 2 6740 switches.

 

The problem I'm having is, we're looking to seperate out 2 VX-Rail's for VDI purposes and therefore been asked to put them in a seperate VLAN from the other 2 units. In order to do this, we've configured "a" new vlan on our existing network and the idea was to replicate this information on the brocade swithces as well. However, the problem we're having is, when we set the ports on our existing switches to a "trunk" port, nothing works, no information is passed on the new vlan or the exisiting vlan, however as soon as we change this to the "access" port, the existing vlan works. Therefore I've tried replicating the current config to see where I could be wrong but unable to find any hard evidence which confirms this.

 

Therefore I'm looking to see, if anyone here has any experience in setting this up, it's pretty straight-forward in what we're looking to do however, since we're not very familiar with Brocade's terminology and configurations, it's is turning out to be a bit difficult.

 

Below are some config from the Brocade swithces:

 

VDX1# show running-config interface te 1/0/1
interface TenGigabitEthernet 1/0/1
 channel-group 1 mode on type standard
 fabric isl enable
 fabric trunk enable
 no shutdown
!
VDX1# show running-config interface te 1/0/2
interface TenGigabitEthernet 1/0/2
 channel-group 2 mode on type standard
 fabric isl enable
 fabric trunk enable
 no shutdown
!

VDX1# show runinning-config interface Port-channel 1
interface Port-channel 1
 no vlag ignore-split
 speed 1000
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 2,203
 switchport trunk tag native-vlan
 spanning-tree shutdown
 no shutdown
!
VDX1# show running-config interface Port-channel 1 2
interface Port-channel 2
 no vlag ignore-split
 speed 1000
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 2,203
 switchport trunk tag native-vlan
 spanning-tree shutdown
 no shutdown
!
port-channel-redundancy-group 1
 port-channel 1 active
 port-channel 2
 activate
!




interface Vlan 1
 ip igmp snooping enable
 ip igmp snooping querier enable
 ipv6 mld snooping enable
 ipv6 mld snooping querier enable
!
interface Vlan 2
 name management
 ip igmp snooping enable
 ip igmp snooping querier enable
 ipv6 mld snooping enable
 ipv6 mld snooping querier enable
!
interface Vlan 200
 name vsan
 ip igmp snooping enable
 ip igmp snooping querier enable
 ipv6 mld snooping enable
 ipv6 mld snooping querier enable
!
interface Vlan 201
 name vmotion
 ip igmp snooping enable
--More--         ip igmp snooping querier enable
 ipv6 mld snooping enable
 ipv6 mld snooping querier enable
!
interface Vlan 203
 name VDI Management
 ip igmp snooping enable
 ip igmp snooping querier enable
 ipv6 mld snooping enable
 ipv6 mld snooping querier enable
!
interface Vlan 204
 name VDI vmotion
 ip igmp snooping enable
 ip igmp snooping querier enable
 ipv6 mld snooping enable
 ipv6 mld snooping querier enable
!
interface Vlan 205
 name VDI vsan
 ip igmp snooping enable
 ip igmp snooping querier enable
 ipv6 mld snooping enable
--More--         ipv6 mld snooping querier enable
!
fabric route mcast rbridge-id 1
!
fabric route mcast rbridge-id 2
!


rbridge-id 1
 ip route 0.0.0.0/0 10.1.3.254
 switch-attributes chassis-name VDX6740
 switch-attributes host-name VDX1
 vrf mgmt-vrf
  address-family ipv4 unicast
   ip route 0.0.0.0/0 10.1.3.254
  !
  address-family ipv6 unicast
  !
 !
system-monitor fan threshold marginal-threshold 1 down-threshold 2
 system-monitor fan alert state removed action raslog
 system-monitor power threshold marginal-threshold 1 down-threshold 2
 system-monitor power alert state removed action raslog
 system-monitor temp threshold marginal-threshold 1 down-threshold 2
 system-monitor cid-card threshold marginal-threshold 1 down-threshold 2
 system-monitor cid-card alert state none action none
 system-monitor sfp alert state none action none
 system-monitor compact-flash threshold marginal-threshold 1 down-threshold 0
 system-monitor MM threshold marginal-threshold 1 down-threshold 0
 system-monitor LineCard threshold marginal-threshold 1 down-threshold 2
 system-monitor LineCard alert state none action none
 system-monitor SFM threshold marginal-threshold 1 down-threshold 2
 qos tx-queue limit 2000
 qos rcv-queue limit 2000
 no protocol vrrp
 no protocol vrrp-extended
 hardware-profile tcam default
 hardware-profile route-table default maximum_paths 8 openflow off
 hardware-profile kap default
 clock timezone Etc/GMT
 ag
  enable
counter reliability 25
  timeout fnm 120
  pg 0
   modes lb
   rename pg0
  !
 !
 telnet server use-vrf default-vrf
 telnet server use-vrf mgmt-vrf
 ssh server key rsa 2048
 ssh server key ecdsa 256
 ssh server key dsa
 ssh server use-vrf default-vrf
 ssh server use-vrf mgmt-vrf
 fcoe
  fcoe-enodes 0
 !
!
rbridge-id 2
 ip route 0.0.0.0/0 10.1.3.254
 switch-attributes chassis-name VDX6740
 switch-attributes host-name VDX2
 vrf mgmt-vrf
--More--          address-family ipv4 unicast
   ip route 0.0.0.0/0 10.1.3.254
  !
  address-family ipv6 unicast
  !
 !
 system-monitor fan threshold marginal-threshold 1 down-threshold 2
 system-monitor fan alert state removed action raslog
 system-monitor power threshold marginal-threshold 1 down-threshold 2
 system-monitor power alert state removed action raslog
 system-monitor temp threshold marginal-threshold 1 down-threshold 2
 system-monitor cid-card threshold marginal-threshold 1 down-threshold 2
 system-monitor cid-card alert state none action none
 system-monitor sfp alert state none action none
 system-monitor compact-flash threshold marginal-threshold 1 down-threshold 0
 system-monitor MM threshold marginal-threshold 1 down-threshold 2
 system-monitor LineCard threshold marginal-threshold 1 down-threshold 2
 system-monitor LineCard alert state none action none
 system-monitor SFM threshold marginal-threshold 1 down-threshold 2
 qos tx-queue limit 2000
 qos rcv-queue limit 2000
 no protocol vrrp
 no protocol vrrp-extended
--More--         hardware-profile tcam default
 hardware-profile route-table default maximum_paths 8 openflow off
 hardware-profile kap default
 clock timezone Etc/GMT
 ag
  enable
  counter reliability 25
  timeout fnm 120
  pg 0
   modes lb
   rename pg0
  !
 !
 telnet server use-vrf default-vrf
 telnet server use-vrf mgmt-vrf
 ssh server key rsa 2048
 ssh server key ecdsa 256
 ssh server key dsa
 ssh server use-vrf default-vrf
 ssh server use-vrf mgmt-vrf
 fcoe
  fcoe-enodes 0
 !

If all looks ok on this, then please let me know and I can then share my config on the existing Nortel switches.

 

Cheers!!!

Brocade Moderator
Posts: 226
Registered: ‎06-30-2010

Re: VDX6740 - VXRail Setup!

Hi,

 

A topology diagram would be useful and also configuration of other end switches

 

What is the reason you are using port-channel redundancy group?

 

Could you also supply output from command show port-channel detail

 

Regards

Mick


If my response has solved your query please click the "Accept as Solution" button.

Any and all information provided by me is not reviewed, approved or endorsed by Brocade and is provided solely as a convenience for Brocade customers.

All systems and all networks are different and unique. If you have a service affecting network problem, please open a TAC service request for service through Brocade, or through your OEM equipment provider.
Occasional Contributor
Posts: 8
Registered: ‎04-07-2017

Re: VDX6740 - VXRail Setup!

[ Edited ]

Mick.Day wrote:

Hi,

 

A topology diagram would be useful and also configuration of other end switches

 

What is the reason you are using port-channel redundancy group?

 

Could you also supply output from command show port-channel detail

 

Regards

Mick


Hello Mick,

 

Thanks for your reply.

 

1. I have attached the Topology Diagram and config of other switches is below, However, instead of pasting the full switch config, I've omitted it to the necessary bits:

 

!
! *** VLAN ***
!
vlan configcontrol autopvid
auto-pvid
vlan name 1 "VLAN #1"
vlan create 2 name "Server" type port
vlan create 203 name "HCI VLAN" type port
vlan ports 1/31 tagging unTagPvidOnly  filter-untagged-frame disable filter-unregistered-frames disable priority 0
vlan ports 2/31 tagging unTagPvidOnly  filter-untagged-frame disable filter-unregistered-frames disable priority 0
vlan members 1 1/31,1/48,2/31,2/48
vlan members 2 1/31,1/48,2/31,2/48
vlan members 203 1/31,1/48,2/31,2/48
vlan ports 1/31 pvid 2
vlan ports 2/31 pvid 2
vlan mgmt 1
!
! *** Interface ***
!
interface FastEthernet ALL
default auto-negotiation-advertisements port 1/1-47,2/ALL 
name port 1/31 "Brocade-sw1-1 Uplink MLT"
name port 2/31 "Brocade-sw2-1 Uplink MLT"
snmp trap link-status port 1/ALL,2/ALL enable
speed port 1/ALL,2/ALL auto
duplex port 1/ALL,2/ALL auto
exit
interface FastEthernet ALL
rate-limit port 1/ALL,2/ALL both 0
exit
!
! *** MLT (Phase 1) ***
!
no mlt
mlt 2 name "link to Brocade" enable member 1/31,2/31 learning normal
mlt 2 learning normal
mlt 2 bpdu all-ports
mlt 2 loadbalance basic
!
! *** LACP ***
!
lacp mode port 1/28-31 off
lacp key port 1/31 55
lacp timeout-time port 1/31 short
lacp mode port 2/28-31 off
lacp key port 2/31 55
lacp timeout-time port 2/31 short
lacp aggregation port 1/31,2/31 enable
exit
spanning-tree stp 1 add-vlan 1
spanning-tree stp 1 add-vlan 2
spanning-tree stp 1 add-vlan 203
interface FastEthernet ALL
spanning-tree port 1/31 learning normal 
spanning-tree port 2/31 learning normal 
spanning-tree port 1/31 priority 80
spanning-tree port 2/31 priority 80
spanning-tree bpdu-filtering port 1/ALL timeout 120
no spanning-tree bpdu-filtering port 1/ALL enable
spanning-tree bpdu-filtering port 2/ALL timeout 120
no spanning-tree bpdu-filtering port 2/ALL enable
exit
!
! *** MLT (Phase 2) ***
!
mlt spanning-tree 2 stp 1 learning normal
exit

 

2. Hopefully this should answer by looking at the topology diagram.

 

3. Output from "show port-channel detail" :

VDX1# show port-channel detail 
 Static Aggregator: Po 1 (vLAG)
 Aggregator type: Standard
  Member rbridges:
    rbridge-id: 1 (1)
    rbridge-id: 2 (1)
 Member ports on rbridge-id 1
   Te 1/0/1   *

 Member ports on rbridge-id 2
   Te 2/0/1   


 Static Aggregator: Po 2 
 Aggregator type: Standard
 Member ports on rbridge-id 1
   Te 1/0/2   

 Member ports on rbridge-id 2
   Te 2/0/2   

VDX1# exit

 

I should also mention this,

1. When I change the Port 1/31 and 2/31 to the TRUNK port and have PVID set to 1,2 or 203 > Nothing works. (Doesn't make sense)

2. When I change the Port 1/31 and 2/31 to the ACCESS port and have PVID set to 1, 2 or 203 >  Only VLAN which is set as PVID works. (Makes sense)

3. When I change the Port 1/31 and 2/31 to the UnTagPVID port and have PVID set to 1, 2 or 203 > Only VLAN which is set as PVID works. (Doesn't make sense)

 

At the point of time, I've set the ports to UnTagPVID and have PVID set to 2 and it works for that VLAN, If I change the PVID value to 203, Vlan 203 works and Vlan 2 stops working. All I am looking for is have both VLAN work on these ports.

 

Hope this make sense.

 

Looking forward to your reply.

 

Cheers!

 

Brocade Moderator
Posts: 226
Registered: ‎06-30-2010

Re: VDX6740 - VXRail Setup!

Hi John,

 

So what you are saying is that only untagged frames exiting from the VXRail are being forwarded by the VDX? In your current configuration unTagPvidOnly PVID will be sent untagged and this is the VLAN that you say works

 

This does not seem to make sense as the configuration of the VDX that you have previously shown:

switchport mode trunk

switchport trunk allowed vlan add 2,203

switchport trunk tag native-vlan

 

For both port channels which should only allow tagged frames from either the configured VLANs (2,203) or the native VLAN (1)

 

In your configuration I presume that you intend for Port-channel 1 to be active and forwarding traffic and Port-channel 2 to be in standby state hence why you are using port-channel-redundancy-group?

 

Is there any reason why you are configuring LAGs as static LAG and not using LACP dynamic LAGs?

 

Which version of NOS are you running on the VDX 6740?

 

In addition could you please include the following comands from VDX

 

show ip interface brief

show vlan brief

 

Regards

Mick

 

 

 

 

 

 


If my response has solved your query please click the "Accept as Solution" button.

Any and all information provided by me is not reviewed, approved or endorsed by Brocade and is provided solely as a convenience for Brocade customers.

All systems and all networks are different and unique. If you have a service affecting network problem, please open a TAC service request for service through Brocade, or through your OEM equipment provider.
Occasional Contributor
Posts: 8
Registered: ‎04-07-2017

Re: VDX6740 - VXRail Setup!

Hello Mick,

 

Thanks for your reply.

 

This does not seem to make sense as the configuration of the VDX that you have previously shown:

 switchport mode trunk

 switchport trunk allowed vlan add 2,203

 switchport trunk tag native-vlan

 

That's what I am getting confused with as well, the port channels are configured to carry traffic for Vlan 2 & 203 and also tagging native-vlan which I believe would be/is 1 (Not best-practice but I know).

 

In your configuration I presume that you intend for Port-channel 1 to be active and forwarding traffic and Port-channel 2 to be in standby state hence why you are using port-channel-redundancy-group?

 

I would like to think so. By the way, it is not us who've configured the Brocade switches, it is the "Brocade Engineer" and we're the customer working with the Nortel side of things. However, we've access to the Brocade switches since it is our equipment therefore we can go on and make changes if needed be. Also, below output confirms this as well:

 

 

VDX1# show running-config port-channel-redundancy-group
port-channel-redundancy-group 1
 port-channel 1 active
 port-channel 2
 activate
!

 

 

Is there any reason why you are configuring LAGs as static LAG and not using LACP dynamic LAGs?

I'm not very familiar with the Brocade switches and it is not us who've configured it anyway, they've been configured remotely by the brocade engineer.

 

Which version of NOS are you running on the VDX 6740?

The version is 6.0.2c.

 

show ip interface brief

show vlan brief

 

 

VDX1# show ip interface br

Interface                      IP-Address      Vrf                     Status                    Protocol
==========================     ==========      ==================      ====================      ========
Port-channel 1                  unassigned                             up                        up  
Port-channel 2                  unassigned                             up                        down
FortyGigabitEthernet 1/0/49     unassigned        default-vrf          up                        down
FortyGigabitEthernet 1/0/50     unassigned        default-vrf          up                        down
FortyGigabitEthernet 1/0/51     unassigned        default-vrf          up                        down
FortyGigabitEthernet 1/0/52     unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/1        unassigned        default-vrf          up                        up  
TenGigabitEthernet 1/0/2        unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/3        unassigned        default-vrf          up                        up  
TenGigabitEthernet 1/0/4        unassigned        default-vrf          up                        up  
TenGigabitEthernet 1/0/5        unassigned        default-vrf          up                        up  
TenGigabitEthernet 1/0/6        unassigned        default-vrf          up                        up  
TenGigabitEthernet 1/0/7        unassigned        default-vrf          up                        up  
TenGigabitEthernet 1/0/8        unassigned        default-vrf          up                        up  
TenGigabitEthernet 1/0/9        unassigned        default-vrf          up                        up  
TenGigabitEthernet 1/0/10       unassigned        default-vrf          up                        up  
TenGigabitEthernet 1/0/11       unassigned        default-vrf          up                        up  
TenGigabitEthernet 1/0/12       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/13       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/14       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/15       unassigned        default-vrf          up        down
TenGigabitEthernet 1/0/16       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/17       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/18       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/19       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/20       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/21       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/22       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/23       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/24       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/25       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/26       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/27       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/28       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/29       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/30       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/31       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/32       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/33       unassigned        default-vrf          up                        up  
TenGigabitEthernet 1/0/34       unassigned        default-vrf          up                        up  
TenGigabitEthernet 1/0/35       unassigned        default-vrf          up                        up  
TenGigabitEthernet 1/0/36       unassigned        default-vrf          up                        up  
TenGigabitEthernet 1/0/37       unassigned        default-vrf          up                        up  
TenGigabitEthernet 1/0/38       unassigned        default-vrf          up       
up  
TenGigabitEthernet 1/0/39       unassigned        default-vrf          up                        up  
TenGigabitEthernet 1/0/40       unassigned        default-vrf          up                        up  
TenGigabitEthernet 1/0/41       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/42       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/43       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/44       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/45       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/46       unassigned        default-vrf          up                        down
TenGigabitEthernet 1/0/47       unassigned        default-vrf          up                        up  (ISL)
TenGigabitEthernet 1/0/48       unassigned        default-vrf          up                        up  (ISL)

VDX1# show vlan brief

Total Number of VLANs configured    : 8   
Total Number of VLANs provisioned   : 8   
Total Number of VLANs unprovisioned : 0   
VLAN             Name            State                      Ports           Classification                
(F)-FCoE                                                    (u)-Untagged
(R)-RSPAN                                                   (c)-Converged
(T)-TRANSPARENT                                             (t)-Tagged
================ =============== ========================== =============== ====================
1                default         ACTIVE                     Po 1(t)         
                                                            Po 2(t)         
                                                            Te 2/0/46(t)    
                                                            Te 2/0/39(t)    
                                                            Te 2/0/37(t)    
                                                            Te 2/0/38(t)    
                                                            Te 2/0/40(t)    
                                                            Te 2/0/35(t)    
                                                            Te 2/0/33(t)    
                                                            Te 2/0/11(t)    
                                                            Te 2/0/12(t)    
                                                            Te 2/0/34(t)    
                                                            Te 2/0/9(t)     
                                                            Te 2/0/7(t)     
                                                            Te 2/0/8(t)     
                                                            Te 2/0/5(t)     
                                                            Te 2/0/3(t)     
                                                            Te 2/0/4(t)     
                                                            Te 2/0/6(t)     
                                                            Te 2/0/10(t)    
                                                            Te 2/0/36(t)    
                                                            Te 1/0/46(t)    
                                                            Te 1/0/39(t)    
                                                            Te 1/0/37(t)    
                                                            Te 1/0/38(t)    
                                                            Te 1/0/40(t)    
                                                            Te 1/0/35(t)    
                                                            Te 1/0/11(t)    
                                                            Te 1/0/33(t)    
                                                            Te 1/0/34(t)    
                                                            Te 1/0/9(t)     
                                                            Te 1/0/7(t)     
                                                            Te 1/0/8(t)     
                                                            Te 1/0/5(t)     
                                                            Te 1/0/3(t)     
                                                            Te 1/0/4(t)     
                                                            Te 1/0/6(t)     
                                                            Te 1/0/10(t)    
                                                            Te 1/0/36(t)    

2                management      ACTIVE                     Po 1(t)         
                                                            Po 2(t)         
                                                            Te 2/0/46(t)    
                                                            Te 2/0/35(t)    
                                                            Te 2/0/36(t)    
                                                            Te 2/0/11(t)    
                                                            Te 2/0/33(t)    
                                                            Te 2/0/5(t)     
                                                            Te 2/0/3(t)     
                                                            Te 2/0/4(t)     
                                                            Te 2/0/6(t)     
                                                            Te 2/0/34(t)    
                                                            Te 1/0/46(t)    
                                                            Te 1/0/36(t)    
                                                            Te 1/0/34(t)    
                                                            Te 1/0/11(t)    
                                                            Te 1/0/6(t)     
                                                            Te 1/0/33(t)    
                                                            Te 1/0/3(t)     
                                                            Te 1/0/4(t)     
                                                            Te 1/0/5(t)     
                                                            Te 1/0/35(t)    

200              vsan            ACTIVE                 Te 2/0/35(t)    
                                                            Te 2/0/36(t)    
                                                            Te 2/0/33(t)    
                                                            Te 2/0/5(t)     
                                                            Te 2/0/6(t)     
                                                            Te 2/0/3(t)     
                                                            Te 2/0/4(t)     
                                                            Te 2/0/34(t)    
                                                            Te 1/0/36(t)    
                                                            Te 1/0/34(t)    
                                                            Te 1/0/6(t)     
                                                            Te 1/0/33(t)    
                                                            Te 1/0/3(t)     
                                                            Te 1/0/4(t)     
                                                            Te 1/0/5(t)     
                                                            Te 1/0/35(t)    

201              vmotion         ACTIVE                     Te 2/0/35(t)    
                                                            Te 2/0/36(t)    
                                                            Te 2/0/33(t)    
                                                            Te 2/0/5(t)     
                                                            Te 2/0/6(t)     
                                                            Te 2/0/3(t)     
                                                            Te 2/0/4(t)     
                                                            Te 2/0/34(t)    
                                                            Te 1/0/36(t)    
                                                            Te 1/0/34(t)    
                                                            Te 1/0/6(t)     
                                                            Te 1/0/33(t)    
                                                            Te 1/0/3(t)     
                                                            Te 1/0/4(t)     
                                                            Te 1/0/5(t)     
                                                            Te 1/0/35(t)    

203              VDI Management  ACTIVE                     Po 1(t)         
                                                            Po 2(t)         
                                                            Te 2/0/39(t)    
                                                            Te 2/0/40(t)    
                                                            Te 2/0/12(t)    
                                                            Te 2/0/37(t)    
                                                            Te 2/0/9(t)     
                                                            Te 2/0/7(t)     
                                                            Te 2/0/8(t)     
                                                            Te 2/0/10(t)    
                                                            Te 2/0/38(t)    
                                                            Te 1/0/39(t)    
                                                            Te 1/0/37(t)    
                                                            Te 1/0/38(t)    
                                                            Te 1/0/40(t)    
                                                            Te 1/0/9(t)     
                                                            Te 1/0/7(t)     
                                                            Te 1/0/8(t)     
                                                            Te 1/0/10(t)    

204              VDI vmotion     ACTIVE                     Te 2/0/39(t)    
                                                            Te 2/0/40(t)    
                                                            Te 2/0/12(t)    
                                                            Te 2/0/37(t)    
                                                            Te 2/0/38(t)    
                                                            Te 2/0/9(t)     
                                                            Te 2/0/7(t)     
                                                            Te 2/0/8(t)     
                                                            Te 2/0/10(t)    
                                                            Te 1/0/39(t)    
                                                            Te 1/0/40(t)    
                                                            Te 1/0/37(t)    
                                                            Te 1/0/38(t)    
                                                            Te 1/0/9(t)     
                                                            Te 1/0/7(t)     
                                                            Te 1/0/8(t)     
                                                            Te 1/0/10(t)    

205              VDI vsan        ACTIVE                     Te 2/0/39(t)    
                                                            Te 2/0/40(t)    
                                                            Te 2/0/12(t)    
                                                            Te 2/0/37(t)    
                                                            Te 2/0/38(t)    
                                                            Te 2/0/9(t)     
                                                            Te 2/0/7(t)     
                                                            Te 2/0/8(t)     
                                                            Te 2/0/10(t)    
                                                            Te 1/0/39(t)    
                                                            Te 1/0/40(t)    
                                                            Te 1/0/37(t)    
                                                            Te 1/0/38(t)    
                                                            Te 1/0/9(t)     
                                                            Te 1/0/7(t)     
                                                            Te 1/0/8(t)     
                                                            Te 1/0/10(t)    

1002(F)          VLAN1002        INACTIVE (no member port)   

VDX1# exit

 

 

Cheers!!!

 

Brocade Moderator
Posts: 226
Registered: ‎06-30-2010

Re: VDX6740 - VXRail Setup!

Hi John,

 

From what I can tell everything appears to be configured as would be expected from what you have described, VLANs 1, 2 and 203 are indeed being tagged and forwarded accross port-channel 1 which is up, port-channel 2 is down which I would expect with the redundancy configured.

 

How are you able to confirm connectivity when this is working?  Which hosts are you confirming connectivity with and to which ports of the VDX /other switch are they connected?

 

Which type of switch are the VDX connected to? Avaya/Nortel (CLI)?

 

Do you have a support contract with Brocade for these switches should further interactive troubleshooting be needed?

 

Regards

Mick

 

 

 

 


If my response has solved your query please click the "Accept as Solution" button.

Any and all information provided by me is not reviewed, approved or endorsed by Brocade and is provided solely as a convenience for Brocade customers.

All systems and all networks are different and unique. If you have a service affecting network problem, please open a TAC service request for service through Brocade, or through your OEM equipment provider.
Occasional Contributor
Posts: 8
Registered: ‎04-07-2017

Re: VDX6740 - VXRail Setup!

Hello Mick,

 

How are you able to confirm connectivity when this is working?  Which hosts are you confirming connectivity with and to which ports of the VDX /other switch are they connected?

 

The only way to confirm connectivity when it is working is by pinging the IPs on the VLAN 2 and VLAN 203. Like I said before, the current config on the Nortel switches are set to UnTagPVIDOnly and the PVID is set as 2 (this again works when we change it to Access layer as it will only pass traffic through VLAN 2). We've a File server on one of the VX-Rail's which is on VLAN 2. While having this setting, we can ping the File server from our Internal network, we switch the PVID to 203, we can ping the IP we've reseverved for the Management interface on VLAN 203. But we cannot seem to get both ping at the same time. We change the port to TRUNK port, none of them works.

 

 

Which type of switch are the VDX connected to? Avaya/Nortel (CLI)?

They're connected to Nortel 5510 Stack (2x5510s).

 

Do you have a support contract with Brocade for these switches should further interactive troubleshooting be needed?

We do not have a direct contract with Brocade as this done via the Retailer who've provided us with the Kit. However, this process seems to be taking a long time than it should be as we're unable to tell which devices are at fault and not configured. That's why I wanted to post this on the forum in the meantime to see if we can rule-out the obvious.

 

Quick update, the brocade engineer has just got back to us reporting that we should try

 

no fabric isl enable
no fabric trunk enable

on all 4 links (TE 1/0/1, 1/0/2 & 2/0/1, 2/0/2). I've scheduled to test this tomorrow morning and will update this thread accordingly.

 

Cheers!!

 

Occasional Contributor
Posts: 8
Registered: ‎04-07-2017

Re: VDX6740 - VXRail Setup!


johncameron wrote:

Hello Mick,

 

How are you able to confirm connectivity when this is working?  Which hosts are you confirming connectivity with and to which ports of the VDX /other switch are they connected?

 

The only way to confirm connectivity when it is working is by pinging the IPs on the VLAN 2 and VLAN 203. Like I said before, the current config on the Nortel switches are set to UnTagPVIDOnly and the PVID is set as 2 (this again works when we change it to Access layer as it will only pass traffic through VLAN 2). We've a File server on one of the VX-Rail's which is on VLAN 2. While having this setting, we can ping the File server from our Internal network, we switch the PVID to 203, we can ping the IP we've reseverved for the Management interface on VLAN 203. But we cannot seem to get both ping at the same time. We change the port to TRUNK port, none of them works.

 

 

Which type of switch are the VDX connected to? Avaya/Nortel (CLI)?

They're connected to Nortel 5510 Stack (2x5510s).

 

Do you have a support contract with Brocade for these switches should further interactive troubleshooting be needed?

We do not have a direct contract with Brocade as this done via the Retailer who've provided us with the Kit. However, this process seems to be taking a long time than it should be as we're unable to tell which devices are at fault and not configured. That's why I wanted to post this on the forum in the meantime to see if we can rule-out the obvious.

 

Quick update, the brocade engineer has just got back to us reporting that we should try

 

no fabric isl enable
no fabric trunk enable

on all 4 links (TE 1/0/1, 1/0/2 & 2/0/1, 2/0/2). I've scheduled to test this tomorrow morning and will update this thread accordingly.

 

Cheers!!

 


Quick update - We did the changes as we were asked and that didn't make any difference as I expected.

 

Anyway, I've got few things which I'll be testing out on Monday and see if that does the trick, and if it does then I'll post it here in-case anyone has the same issue.

 

However, if anyone has any other suggestions then please let me know.

 

Cheers!!

 

Occasional Contributor
Posts: 8
Registered: ‎04-07-2017

Re: VDX6740 - VXRail Setup!

Just a quick update, tested various settings but still no luck and we're back to square one.

 

Is there any way to find out whether the tagged packets are getting discarded by the Brocade switches at all? Since, if the port is an access port, or if the switches forward the untag packets, it works, however, I'm unable to find out why are the tagged packets not working even though all the configurations looks ok (generally).

 

Would it be easier if I attach the full config of both (Nortel stack) and the Brocade switches, to find out if we're missing the key piece of the puzzle?


Cheers!!

 

Brocade Moderator
Posts: 226
Registered: ‎06-30-2010

Re: VDX6740 - VXRail Setup!

Hi John,

 

Sorry you are still struggling getting this to work

 

You could try configuring a monitor session and capture the packets coming from the Nortel stack to confirm they are tagged as you expect.

 

The more information you can provide the better

 

Regards

Mick


If my response has solved your query please click the "Accept as Solution" button.

Any and all information provided by me is not reviewed, approved or endorsed by Brocade and is provided solely as a convenience for Brocade customers.

All systems and all networks are different and unique. If you have a service affecting network problem, please open a TAC service request for service through Brocade, or through your OEM equipment provider.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.