vADC Docs

Compatibility Matrix for Brocade Services Director and Traffic Manager

by PaulWallace ‎04-12-2017 04:14 AM - edited ‎05-09-2017 04:34 AM (432 Views)

The Brocade Services Director makes it easy to manage a fleet of virtual ADC services, with each application supported by dedicated vADC instances, such as Brocade Virtual Traffic Manager (Brocade vTM). In fact, Services Director can even support mixed versions of Brocade vTM, which means that some applications can be managed with an older version of Brocade vTM, while others with the very latest version of Brocade vTM.

 

Generally speaking, compatibility with older, supported versions of Services Director will be maintained in each new vTM release. In other words, you should be able to upgrade vTM without losing Services Director functionality. Some Service Director features rely on changes introduced into vTM, and will only be available when Services Director is managing vTM versions that expose the feature in question.

 

This table summarises the compatibility between supported versions of Services Director and Virtual Traffic Manager:

 

 

Brocade Services Director

 

2.4

(LTS)

2.5

2.6

17.1

17.2

Brocade vTM

 

 

 

 

 

9.9 (LTS)

1

1

1

1

1

10.4 (LTS)

Y

1

1

1

1

11.0

Y

Y

Y

Y

Y

11.1

Y

Y

Y

Y

Y

17.1

Y

Y

Y

Y

Y

 

 

Key to the Table

  Y  

This combination is fully compatible, supporting all capabilities which are
supported in both of the corresponding versions of SD and vTM

  1  

This combination is compatible, but some features are NOT fully supported,
depending on the respective versions of SD and vTM

 

 

Limitations of feature support:

Although the table above indicates that most combinations are supported to some extent, some key capabilities are of course dependent on the respective versions of SD and of vTM. The capability must be available by both your installation of Services Director and the instance of vTM, in order to be fully functional.

 

For example, the capability for instances of vTM to “Self-Register” with Services Director is only supported in Services Director 2.4 and higher, and in vTM versions 10.4 and higher:

 

Example SD Capability

Available from which version

 

Services Director

vTM

vTM Cluster Awareness

2.3

10.3

vTM Instance Health

2.4

10.2

vTM Self Registration

2.4

10.4

vTM Backup/Restore

2.5

11.0

 

 

This data is correct at the time of last update - April 2017. For combinations of SD and vTM not shown in this table, please contact your Brocade technical sales representative.

 

 

Contributors